<!doctype html>
<!--[if lt IE 7]><html
class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]><html
class="no-js lt-ie9 lt-ie8" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]><html
class="no-js lt-ie9" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]><html
class="no-js lt-ie10" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 8]><!--><html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <!--<![endif]--><head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' /><link rel="profile" href="https://gmpg.org/xfn/11" /><link rel="pingback" href="https://www.lawofficer.com/xmlrpc.php" /><title>Ohio mother charged with murder after son&#8217;s decomposing body found under pile of clothes &#8211; Law Officer</title><style type="text/css">.heateorSssInstagramBackground{background:radial-gradient(circle at 30% 107%,#fdf497 0,#fdf497 5%,#fd5949 45%,#d6249f 60%,#285aeb 90%)}.heateor_sss_horizontal_sharing .heateorSssSharing,.heateor_sss_standard_follow_icons_container .heateorSssSharing{color:#fff;border-width:0;border-style:solid;border-color:transparent}.heateor_sss_horizontal_sharing .heateorSssTCBackground{color:#666}.heateor_sss_horizontal_sharing .heateorSssSharing:hover,.heateor_sss_standard_follow_icons_container .heateorSssSharing:hover{border-color:transparent}.heateor_sss_vertical_sharing .heateorSssSharing,.heateor_sss_floating_follow_icons_container .heateorSssSharing{color:#fff;border-width:0;border-style:solid;border-color:transparent}.heateor_sss_vertical_sharing .heateorSssTCBackground{color:#666}.heateor_sss_vertical_sharing .heateorSssSharing:hover,.heateor_sss_floating_follow_icons_container .heateorSssSharing:hover{border-color:transparent}@media screen and (max-width:783px){.heateor_sss_vertical_sharing{display:none!important}}@media screen and (max-width:783px){.heateor_sss_floating_follow_icons_container{display:none!important}}</style><meta name='robots' content='max-image-preview:large' /><meta property="og:type" content="article"><meta property="og:title" content="Ohio mother charged with murder after son&#8217;s decomposing body found under pile of clothes"><meta property="og:site_name" content="Law Officer"><meta property="og:description" content="CINCINNATI -- An Ohio mom accused of killing her 19-year-old son and hiding his body under a pile of clothes in a bedroom"><meta property="og:url" content="https://www.lawofficer.com/ohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes/"><meta property="og:locale" content="en_US"><meta property="og:image" content="https://www.lawofficer.com/wp-content/uploads/2021/04/Kenya-Stallworth-e1618492463423.png"><meta property="og:image:height" content="360"><meta property="og:image:width" content="640"><meta property="article:published_time" content="2021-04-15T13:25:59+00:00"><meta property="article:modified_time" content="2021-04-15T13:30:51+00:00"><meta property="article:author" content="https://www.facebook.com/lawofficer/"><meta property="article:section" content="Investigations"><meta property="article:tag" content="cincinnati"><meta property="article:tag" content="Dominic Allen"><meta property="article:tag" content="Hamilton County"><meta property="article:tag" content="Kenya Stallworth"><meta property="article:tag" content="ohio"><meta property="article:tag" content="Robert Robb"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:title" content="Ohio mother charged with murder after son&#8217;s decomposing body found under pile of clothes"><meta name="twitter:description" content="CINCINNATI -- An Ohio mom accused of killing her 19-year-old son and hiding his body under a pile of clothes in a bedroom"><meta name="twitter:url" content="https://www.lawofficer.com/ohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes/"><meta name="twitter:site" content="https://twitter.com/lawofficer"><meta name="twitter:image:src" content="https://www.lawofficer.com/wp-content/uploads/2021/04/Kenya-Stallworth-e1618492463423.png"><meta name="twitter:image:width" content="640"><meta name="twitter:image:height" content="360"><meta property="fb:app_id" content="581238329089601"> <script type="text/javascript">var jnews_ajax_url='/?ajax-request=jnews'</script> <link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Law Officer &raquo; Feed" href="https://www.lawofficer.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Law Officer &raquo; Comments Feed" href="https://www.lawofficer.com/comments/feed/" /><style type="text/css" media="all">@font-face{font-family:'Roboto';font-display:block;font-style:normal;font-weight:400;font-display:swap;src:url(https://fonts.gstatic.com/s/roboto/v27/KFOmCnqEu92Fr1Mu4mxM.woff) format('woff')}@font-face{font-family:'Roboto';font-display:block;font-style:normal;font-weight:500;font-display:swap;src:url(https://fonts.gstatic.com/s/roboto/v27/KFOlCnqEu92Fr1MmEU9fBBc-.woff) format('woff')}@font-face{font-family:'Roboto';font-display:block;font-style:normal;font-weight:700;font-display:swap;src:url(https://fonts.gstatic.com/s/roboto/v27/KFOlCnqEu92Fr1MmWUlfBBc-.woff) format('woff')}@font-face{font-family:'Roboto Condensed';font-display:block;font-style:normal;font-weight:400;font-display:swap;src:url(https://fonts.gstatic.com/s/robotocondensed/v19/ieVl2ZhZI2eCN5jzbjEETS9weq8-19K7Cw.woff) format('woff')}</style><link rel='stylesheet' id='wpo_min-header-0-css' href='https://www.lawofficer.com/wp-content/cache/wpo-minify/1618438189/assets/wpo-minify-header-5a6c6206.min.css' type='text/css' media='all' /> <script type='text/javascript' src='https://www.lawofficer.com/wp-content/cache/wpo-minify/1618438189/assets/wpo-minify-header-84e60a2d.min.js' id='wpo_min-header-0-js'></script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-92227258-1' id='google_gtagjs-js' async></script> <script type='text/javascript' id='google_gtagjs-js-after'>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments)}
gtag("js",new Date());gtag("set","developer_id.dZTNiMT",!0);gtag("config","UA-92227258-1",{"anonymize_ip":!0})</script> <link rel="https://api.w.org/" href="https://www.lawofficer.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.lawofficer.com/wp-json/wp/v2/posts/116522" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.lawofficer.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.lawofficer.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.7.1" /><link rel="canonical" href="https://www.lawofficer.com/ohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes/" /><link rel='shortlink' href='https://www.lawofficer.com/?p=116522' /><link rel="alternate" type="application/json+oembed" href="https://www.lawofficer.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.lawofficer.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F&#038;format=xml" /><meta name="generator" content="Site Kit by Google 1.30.0" /><meta property="fb:app_id" content="581238329089601" /><meta property="fb:admins" content="https://www.facebook.com/TPRKevin" /><meta property="fb:admins" content="https://www.facebook.com/jaketravis17" /><meta property="fb:admins" content="https://www.facebook.com/jim.mcneff.3" /><script data-ad-client="ca-pub-6064890040415786" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=!0;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f)})(window,document,'script','dataLayer','GTM-55GV97M')</script> <script src="//cdn.marphezis.com/ono/ono-lwo.js" async></script> <div id="fb-root"></div> <script>window.fbAsyncInit=function(){FB.init({appId:'581238329089601',xfbml:!0,version:'v9.0'});FB.AppEvents.logPageView()};(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}
js=d.createElement(s);js.id=id;js.src="https://connect.facebook.net/en_US/sdk.js";fjs.parentNode.insertBefore(js,fjs)}(document,'script','facebook-jssdk'))</script> <meta property="fb:app_id" content="581238329089601" /><meta property="fb:admins" content="10225820706570660" /><meta property="og:url" content="URL" /><meta property="og:title" content="TITLE" /><meta property="og:description" content="DESC" /><meta property="og:image" content="IMG" /><meta name="google-site-verification" content="gbOdDkPYt7Wl1oyEg7WgUms4l8AKU2Z5_fzGnXXhqZ0"><meta name="onesignal" content="wordpress-plugin" /> <script>window.OneSignal=window.OneSignal||[];OneSignal.push(function(){OneSignal.SERVICE_WORKER_UPDATER_PATH="OneSignalSDKUpdaterWorker.js.php";OneSignal.SERVICE_WORKER_PATH="OneSignalSDKWorker.js.php";OneSignal.SERVICE_WORKER_PARAM={scope:"/"};OneSignal.setDefaultNotificationUrl("https://www.lawofficer.com");var oneSignal_options={};window._oneSignalInitOptions=oneSignal_options;oneSignal_options.wordpress=!0;oneSignal_options.appId='e1a2ce64-ef3a-4530-9082-b9308b9b7a58';oneSignal_options.allowLocalhostAsSecureOrigin=!0;oneSignal_options.welcomeNotification={};oneSignal_options.welcomeNotification.title="Law Officer Notifications";oneSignal_options.welcomeNotification.message="Thank you for staying informed!";oneSignal_options.path="https://www.lawofficer.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";oneSignal_options.safari_web_id="web.onesignal.auto.1ee85315-99d2-4859-abe2-d0d2d86b4cd7";oneSignal_options.persistNotification=!0;oneSignal_options.promptOptions={};oneSignal_options.promptOptions.actionMessage="Stay informed with Law Officer Notifications! (You can shut off anytime)";oneSignal_options.promptOptions.exampleNotificationTitleDesktop="Law Officer Notifications";oneSignal_options.promptOptions.cancelButtonText="Not Now";oneSignal_options.promptOptions.siteName="Law Officer";oneSignal_options.notifyButton={};oneSignal_options.notifyButton.enable=!0;oneSignal_options.notifyButton.position='bottom-left';oneSignal_options.notifyButton.theme='default';oneSignal_options.notifyButton.size='large';oneSignal_options.notifyButton.showCredit=!1;oneSignal_options.notifyButton.text={};oneSignal_options.notifyButton.text['tip.state.unsubscribed']='Get Law Officer updates!';oneSignal_options.notifyButton.text['tip.state.subscribed']='Law Officer Notifications: On';oneSignal_options.notifyButton.text['tip.state.blocked']='You&#039;ve blocked Law Officer updates';oneSignal_options.notifyButton.text['message.action.subscribed']='We&#039;ll keep you updated!';oneSignal_options.notifyButton.text['message.action.resubscribed']='You&#039;ll receive Law Officer updates (again)';oneSignal_options.notifyButton.text['message.action.unsubscribed']='Law Officer updates are now off.';oneSignal_options.notifyButton.text['dialog.main.title']='Law Officer Notifications';oneSignal_options.notifyButton.text['dialog.main.button.subscribe']='Click here to stay updated!';oneSignal_options.notifyButton.text['dialog.main.button.unsubscribe']='Shut off updates';oneSignal_options.notifyButton.text['dialog.blocked.title']='Unblock Law Officer Updates';oneSignal_options.notifyButton.colors={};oneSignal_options.notifyButton.colors['circle.background']='#112549';oneSignal_options.notifyButton.colors['dialog.button.background']='#3de725';OneSignal.init(window._oneSignalInitOptions);OneSignal.showSlidedownPrompt()});function documentInitOneSignal(){var oneSignal_elements=document.getElementsByClassName("OneSignal-prompt");var oneSignalLinkClickHandler=function(event){OneSignal.push(['registerForPushNotifications']);event.preventDefault()};for(var i=0;i<oneSignal_elements.length;i++)
oneSignal_elements[i].addEventListener('click',oneSignalLinkClickHandler,!1);}
if(document.readyState==='complete'){documentInitOneSignal()}else{window.addEventListener("load",function(event){documentInitOneSignal()})}</script> <meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." /> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle=window.adsbygoogle||[]).push({"google_ad_client":"ca-pub-6064890040415786","enable_page_level_ads":!0,"tag_partner":"site_kit"})</script><script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","@id":"https:\/\/www.lawofficer.com\/#organization","url":"https:\/\/www.lawofficer.com\/","name":"","logo":{"@type":"ImageObject","url":""},"sameAs":["https:\/\/www.facebook.com\/LawOfficer","https:\/\/www.linkedin.com\/groups\/1786754\/  ","https:\/\/www.instagram.com\/lawofficeracademy\/","https:\/\/twitter.com\/lawofficer","https:\/\/www.lawofficer.com\/feed"]}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"https:\/\/www.lawofficer.com\/#website","url":"https:\/\/www.lawofficer.com\/","name":"","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.lawofficer.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <link rel="icon" href="https://www.lawofficer.com/wp-content/uploads/2021/01/cropped-lawofficer-facebook-b-w-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.lawofficer.com/wp-content/uploads/2021/01/cropped-lawofficer-facebook-b-w-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.lawofficer.com/wp-content/uploads/2021/01/cropped-lawofficer-facebook-b-w-180x180.png" /><meta name="msapplication-TileImage" content="https://www.lawofficer.com/wp-content/uploads/2021/01/cropped-lawofficer-facebook-b-w-270x270.png" /> <script>window.fbAsyncInit=function(){FB.init({appId:'581238329089601',xfbml:!0,version:'v5.0'});FB.AppEvents.logPageView()};(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}
js=d.createElement(s);js.id=id;js.src="https://connect.facebook.net/en_US/sdk.js";fjs.parentNode.insertBefore(js,fjs)}(document,'script','facebook-jssdk'))</script><style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><style type="text/css">.no_thumbnail .jeg_thumb,.thumbnail-container.no_thumbnail{display:none!important}.jeg_search_result .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,.jeg_sidefeed .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,.jeg_pl_sm.no_thumbnail .jeg_postblock_content{margin-left:0}.jeg_postblock_11 .no_thumbnail .jeg_postblock_content,.jeg_postblock_12 .no_thumbnail .jeg_postblock_content,.jeg_postblock_12.jeg_col_3o3 .no_thumbnail .jeg_postblock_content{margin-top:0}.jeg_postblock_15 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,.jeg_postblock_19 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,.jeg_postblock_24 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,.jeg_sidefeed .jeg_pl_md_box .jeg_postblock_content{position:relative}.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a,.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a:hover,.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_meta .fa{color:#212121!important}</style><style type="text/css" id="wp-custom-css">.jeg_navbar_dark.jeg_navbar_boxed .jeg_nav_row,.jeg_navbar_dark:not(.jeg_navbar_boxed){background:#112549}.jeg_header .jeg_navbar_menuborder .jeg_main_menu>li:not(:last-child),.jeg_header .jeg_navbar_menuborder .jeg_nav_item,.jeg_navbar_boxed .jeg_nav_row,.jeg_header .jeg_navbar_menuborder:not(.jeg_navbar_boxed) .jeg_nav_left .jeg_nav_item:first-child{border-color:#112549}.custom_post_template h1.jeg_post_title{font-size:2rem;line-height:1.1;font-weight:700;margin:0 0 .4em;letter-spacing:-.04em}.jeg_block_loadmore a{color:#007cba}.jeg_block_title{overflow-wrap:normal}.loln-contact{color:#fff;font-family:inherit;font-weight:400}.klicked-ads{margin:20px 0}.klicked-ads:before{content:"advertisement — story continues below";text-align:center;display:block;font-size:12px;text-transform:uppercase;opacity:.4;margin-bottom:5px}</style><noscript><style>.wpb_animate_when_almost_visible{opacity:1}</style></noscript><meta property="og:locale" content="en_US" /><meta property="og:site_name" content="Law Officer" /><meta property="og:title" content="Ohio mother charged with murder after son&#039;s decomposing body found under pile of clothes" /><meta property="og:url" content="https://www.lawofficer.com/ohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes/" /><meta property="og:type" content="article" /><meta property="og:description" content="CINCINNATI -- An Ohio mom accused of killing her 19-year-old son and hiding his body under a pile of clothes in a bedroom for nearly two months has been indicted on murder and assault charges.
Dominic Allen was missing from late September 2020 until early December, when police found his body inside" /><meta property="og:image" content="https://www.lawofficer.com/wp-content/uploads/2021/04/Kenya-Stallworth-e1618492463423.png" /><meta property="og:image:url" content="https://www.lawofficer.com/wp-content/uploads/2021/04/Kenya-Stallworth-e1618492463423.png" /><meta property="og:image:secure_url" content="https://www.lawofficer.com/wp-content/uploads/2021/04/Kenya-Stallworth-e1618492463423.png" /><meta property="article:published_time" content="2021-04-15T08:25:59-05:00" /><meta property="article:modified_time" content="2021-04-15T08:30:51-05:00" /><meta property="og:updated_time" content="2021-04-15T08:30:51-05:00" /><meta property="article:author" content="https://www.facebook.com/lawofficer/" /><meta property="article:publisher" content="https://www.facebook.com/lawofficer/" /><meta property="fb:app_id" content="581238329089601" /><meta name="twitter:title" content="Ohio mother charged with murder after son&#039;s decomposing body found under pile of clothes" /><meta name="twitter:url" content="https://www.lawofficer.com/ohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes/" /><meta name="twitter:description" content="CINCINNATI -- An Ohio mom accused of killing her 19-year-old son and hiding his body under a pile of clothes in a bedroom for nearly two months has been indicted on murder and assault charges.
Dominic Allen was missing from late September 2020 until early December, when police found his body inside" /><meta name="twitter:image" content="https://www.lawofficer.com/wp-content/uploads/2021/04/Kenya-Stallworth-e1618492463423.png" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@https://twitter.com/lawofficer" /><meta name="twitter:site" content="@lawofficer" /></head><body data-rsssl=1 class="post-template-default single single-post postid-116522 single-format-standard wp-embed-responsive jeg_toggle_dark jnews jsc_normal wpb-js-composer js-comp-ver-6.6.0 vc_responsive"><div class="jeg_ad jeg_ad_top jnews_header_top_ads"><div class='ads-wrapper  '></div></div><div class="jeg_viewport"><div class="jeg_header_wrapper"><div class="jeg_header_instagram_wrapper"></div><div class="jeg_header normal"><div class="jeg_topbar jeg_container normal"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left  jeg_nav_grow"><div class="item_wrap jeg_nav_alignleft"></div></div><div class="jeg_nav_col jeg_nav_center  jeg_nav_normal"><div class="item_wrap jeg_nav_aligncenter"></div></div><div class="jeg_nav_col jeg_nav_right  jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"><div class="jeg_nav_item socials_widget jeg_social_icon_block rounded">
<a href="https://www.facebook.com/LawOfficer" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://www.linkedin.com/groups/1786754/  " target='_blank' class="jeg_linkedin"><i class="fa fa-linkedin"></i> </a><a href="https://www.instagram.com/lawofficeracademy/" target='_blank' class="jeg_instagram"><i class="fa fa-instagram"></i> </a><a href="https://twitter.com/lawofficer" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.lawofficer.com/feed" target='_blank' class="jeg_rss"><i class="fa fa-rss"></i> </a></div></div></div></div></div></div><div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper  jeg_navbar_fitwidth jeg_navbar_menuborder jeg_navbar_dark"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_normal"><div class="item_wrap jeg_nav_alignleft"></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_normal"><div class="item_wrap jeg_nav_aligncenter"><div class="jeg_main_menu_wrapper"><div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li id="menu-item-59924" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-59924 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/">Home</a></li><li id="menu-item-60098" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60098 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/contact/">Contact</a></li><li id="menu-item-90899" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90899 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/about/">About Us</a></li><li id="menu-item-75204" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75204 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/authors/">Authors</a></li><li id="menu-item-89062" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-89062 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/advertise/">Advertise</a></li><li id="menu-item-90637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-90637 bgnav" data-item-row="default"><a href="/">Categories</a><ul class="sub-menu"><li id="menu-item-90627" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90627 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/category/archive/">Archives</a></li><li id="menu-item-90638" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90638 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/category/chaplain/">Chaplain</a></li><li id="menu-item-90641" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90641 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/category/crime-controversy/">Crime &amp; Controversy</a></li><li id="menu-item-90636" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90636 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/category/community-oriented-policing/">Community</a></li><li id="menu-item-90640" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90640 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/category/cop-humor/">Cop Humor</a></li><li id="menu-item-90634" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90634 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/category/editorial/">Editorial</a></li><li id="menu-item-90632" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90632 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/category/op-ed/">Op-ed</a></li><li id="menu-item-90646" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90646 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/category/gear-technology/">Gear &amp; Technology</a></li><li id="menu-item-90629" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-90629 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/category/investigations/">Investigations</a></li><li id="menu-item-90630" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90630 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/category/laws/">Laws &amp; Legal</a></li><li id="menu-item-90633" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90633 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/category/leadership/">Leadership</a></li><li id="menu-item-90644" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-90644 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/category/news/">News</a></li><li id="menu-item-90631" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90631 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/category/officer-down/">Officer Down</a></li><li id="menu-item-90645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90645 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/category/on-duty/">On Duty</a></li><li id="menu-item-90635" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90635 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/category/tactics/">Tactics</a></li></ul></li><li id="menu-item-93321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-93321 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/network/">Network</a><ul class="sub-menu"><li id="menu-item-93322" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93322 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/illinois/">Illinois Network</a></li><li id="menu-item-93323" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93323 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/minneapolis/">Minneapolis Network</a></li><li id="menu-item-93325" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93325 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/tulsa/">Tulsa Network</a></li><li id="menu-item-93324" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93324 bgnav" data-item-row="default"><a href="https://www.lawofficer.com/wauwatosa/">Wauwatosa Network</a></li></ul></li></ul></div></div></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"><div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a><form action="https://www.lawofficer.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"><div class="search-result-wrapper"></div><div class="search-link search-noresult">
No Result</div><div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result</div></div></div></div></div></div></div></div><div class="jeg_midbar jeg_container normal"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_normal"><div class="item_wrap jeg_nav_alignleft"></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_grow"><div class="item_wrap jeg_nav_aligncenter"><div class="jeg_nav_item jeg_logo jeg_desktop_logo"><div class="site-title">
<a href="https://www.lawofficer.com/" style="padding: 0 0 0 0;">
<img class='jeg_logo_img' src="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-bg.png" srcset="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-bg.png 1x, https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-bg.png 2x" alt="Law Officer" data-light-src="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-bg.png" data-light-srcset="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-bg.png 1x, https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-bg.png 2x" data-dark-src="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png" data-dark-srcset="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png 1x, https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png 2x"> </a></div></div></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"></div></div></div></div></div></div></div><div class="jeg_header_sticky"></div><div class="jeg_navbar_mobile_wrapper"><div class="jeg_navbar_mobile" data-mode="fixed"><div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container dark"><div class="container"><div class="jeg_nav_row"><div class="jeg_nav_col jeg_nav_left jeg_nav_normal"><div class="item_wrap jeg_nav_alignleft"><div class="jeg_nav_item">
<a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a></div></div></div><div class="jeg_nav_col jeg_nav_center jeg_nav_normal"><div class="item_wrap jeg_nav_aligncenter"><div class="jeg_nav_item jeg_mobile_logo"><div class="site-title">
<a href="https://www.lawofficer.com/">
<img class='jeg_logo_img' src="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png" srcset="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png 1x, https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png 2x" alt="Law Officer" data-light-src="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png" data-light-srcset="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png 1x, https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png 2x" data-dark-src="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png" data-dark-srcset="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png 1x, https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png 2x"> </a></div></div></div></div><div class="jeg_nav_col jeg_nav_right jeg_nav_normal"><div class="item_wrap jeg_nav_alignright"><div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a><form action="https://www.lawofficer.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"><div class="search-result-wrapper"></div><div class="search-link search-noresult">
No Result</div><div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result</div></div></div></div></div></div></div></div></div><div class="sticky_blankspace" style="height: 72px;"></div></div><div class="post-wrapper"><div class="post-wrap"><div class="jeg_main "><div class="jeg_container"><div class="jeg_content"><div class="jeg_vc_content custom_post_template"><div class="row vc_row wpb_row vc_row-fluid"><div class="jeg-vc-wrapper"><div class="wpb_column jeg_column vc_column_container vc_col-sm-8"><div class="jeg_wrapper wpb_wrapper"><div class='jeg_custom_title_wrapper  '><h1 class="jeg_post_title">Ohio mother charged with murder after son&#8217;s decomposing body found under pile of clothes</h1></div><div class='jeg_custom_subtitle_wrapper  '><h2 class="jeg_post_subtitle">Police said the woman and her husband tried to seal off the room to stop the foul odor from escaping</h2></div><div class='jeg_post_meta jeg_custom_meta_wrapper  '><div class='meta_left'><div class="jeg_meta_date">
<a href="https://www.lawofficer.com/ohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes/">April 15, 2021</a></div><div class="jeg_meta_author"><img alt='Law Officer' src='https://www.lawofficer.com/wp-content/uploads/2021/01/cropped-lawofficer-facebook-b-w-150x150.png' srcset='https://www.lawofficer.com/wp-content/uploads/2021/01/cropped-lawofficer-facebook-b-w-180x180.png 2x' class='avatar avatar-80 photo' height='80' width='80' loading='lazy' /><span class="meta_text">by</span><a href="https://www.lawofficer.com/author/lawofficer/">Law Officer</a></div><div class="jeg_meta_category">
<span>
<span class="meta_text">in</span>
<a href="https://www.lawofficer.com/category/investigations/" rel="category tag">Investigations</a>, <a href="https://www.lawofficer.com/category/news/" rel="category tag">News</a>
</span></div></div><div class='meta_right'></div></div><div class="jeg_featured featured_image"><a href="https://www.lawofficer.com/wp-content/uploads/2021/04/Kenya-Stallworth-e1618492463423.png"><div class="thumbnail-container" style="padding-bottom:71.467%"><img width="750" height="536" src="https://www.lawofficer.com/wp-content/uploads/2021/04/Kenya-Stallworth-750x536.png" class="attachment-jnews-750x536 size-jnews-750x536 wp-post-image" alt="Ohio mother" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/04/Kenya-Stallworth-750x536.png 750w, https://www.lawofficer.com/wp-content/uploads/2021/04/Kenya-Stallworth-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/04/Kenya-Stallworth-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/04/Kenya-Stallworth-1140x815.png 1140w" sizes="(max-width: 750px) 100vw, 750px" data-full-width="640" data-full-height="360" /></div><p class="wp-caption-text">Kenya Stallworth was indicted on murder and assault charges in the death of her son. (Hamilton County Sheriff's Office)</p></a></div><div class="vc_empty_space" style="height: 12px"><span class="vc_empty_space_inner"></span></div><div class='jeg_custom_share_wrapper '><div class="jeg_share_top_container"><div class="jeg_share_button clearfix"><div class="jeg_share_stats"><div class="jeg_share_count"><div class="counts">362</div>
<span class="sharetext">SHARES</span></div><div class="jeg_views_count"><div class="counts">1.6k</div>
<span class="sharetext">VIEWS</span></div></div><div class="jeg_sharelist"></div></div></div></div><div class="vc_empty_space" style="height: 12px"><span class="vc_empty_space_inner"></span></div><div class='jeg_custom_content_wrapper  '><div class='entry-content  no-share'><div class="jeg_share_button share-float jeg_sticky_share clearfix share-normal"></div><div class='content-inner'><div class='heateorSssClear'></div><div class='heateor_sss_sharing_container heateor_sss_horizontal_sharing' heateor-sss-data-href='https://www.lawofficer.com/ohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes/'><div class='heateor_sss_sharing_title' style="font-weight:bold">Share and speak up for justice, law &amp; order...</div><ul class="heateor_sss_sharing_ul"><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Facebook" Title="Facebook" class="heateorSssSharing heateorSssFacebookBackground" onclick='heateorSssPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssFacebookSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Facebook Messenger" Title="Facebook Messenger" class="heateorSssSharing heateorSssFacebookMessengerBackground" onclick='heateorSssPopup("https://www.facebook.com/dialog/send?app_id=1904103319867886&display=popup&link=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F&redirect_uri=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssFacebookMessengerSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Instagram" Title="Instagram" class="heateorSssSharing heateorSssInstagramBackground"><a href="https://www.instagram.com/@lawofficeracademy" rel="nofollow noopener" target="_blank"><ss style="display:block;" class="heateorSssSharingSvg heateorSssInstagramSvg"></ss></a></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Twitter" Title="Twitter" class="heateorSssSharing heateorSssTwitterBackground" onclick='heateorSssPopup("http://twitter.com/intent/tweet?via=lawofficer&text=Ohio%20mother%20charged%20with%20murder%20after%20son%27s%20decomposing%20body%20found%20under%20pile%20of%20clothes&url=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssTwitterSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Parler" Title="Parler" class="heateorSssSharing heateorSssParlerBackground" onclick='heateorSssPopup("https://parler.com/new-post?message=Ohio%20mother%20charged%20with%20murder%20after%20son%27s%20decomposing%20body%20found%20under%20pile%20of%20clothes&url=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssParlerSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Email" Title="Email" class="heateorSssSharing heateorSssEmailBackground" onclick="window.open('mailto:?subject=' + decodeURIComponent('Ohio%20mother%20charged%20with%20murder%20after%20son%27s%20decomposing%20body%20found%20under%20pile%20of%20clothes' ).replace('&', '%26') + '&body=' + decodeURIComponent('https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F' ), '_blank')"><ss style="display:block" class="heateorSssSharingSvg heateorSssEmailSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Mendeley" Title="Mendeley" class="heateorSssSharing heateorSssMendeleyBackground" onclick='heateorSssPopup("https://www.mendeley.com/sign-in/")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssMendeleySvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Linkedin" Title="Linkedin" class="heateorSssSharing heateorSssLinkedinBackground" onclick='heateorSssPopup("http://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F&title=Ohio%20mother%20charged%20with%20murder%20after%20son%27s%20decomposing%20body%20found%20under%20pile%20of%20clothes")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssLinkedinSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Reddit" Title="Reddit" class="heateorSssSharing heateorSssRedditBackground" onclick='heateorSssPopup("http://reddit.com/submit?url=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F&title=Ohio%20mother%20charged%20with%20murder%20after%20son%27s%20decomposing%20body%20found%20under%20pile%20of%20clothes")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssRedditSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Gab" Title="Gab" class="heateorSssSharing heateorSssGabBackground" onclick='heateorSssPopup("https://gab.com/compose?url=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F&text=Ohio%20mother%20charged%20with%20murder%20after%20son%27s%20decomposing%20body%20found%20under%20pile%20of%20clothes")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssGabSvg"></ss></i></li></ul><div class="heateorSssClear"></div></div><div class='heateorSssClear'></div><br /><p class="speakable"><strong>CINCINNATI</strong> &#8212; An Ohio mom accused of killing her 19-year-old son and hiding his body under a pile of clothes in a bedroom for nearly two months has been indicted on murder and assault charges.</p><p class="speakable">Dominic Allen was missing from late September 2020 until early December, when police found his body inside the home of his mother, Kenya Stallworth, 39, and her husband, Robert Robb, 35, <a href="https://www.fox19.com/2021/04/13/mother-faces-murder-charge-death-son-year-old-dominic-allen/" target="_blank" rel="noopener">FOX19NOW reported</a>.</p><p>Police said the couple tried to seal off the room to stop the foul odor of Allen’s decomposing body from escaping.</p><div class="ad-container desktop"><p>A spokesperson for the Hamilton County Prosecuting Attorney’s Office told <a href="https://www.foxnews.com/us/ohio-mother-murder-sons-body-found-under-clothes" target="_blank" rel="noopener">Fox News</a> Wednesday that it took DNA testing to identify Allen&#8217;s remains.</p><p>Once the identity was confirmed, prosecutors sought the murder indictment against Stallworth.</p><p>A Hamilton County grand jury handed down the indictment against the mother Tuesday. It contains one count of murder and one count of felonious assault.</p><blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Allen’s corpse was found decomposing beneath clothes in his mother’s Westwood home last December. <a href="https://t.co/tG1onOCbx5">https://t.co/tG1onOCbx5</a></p><p>&mdash; FOX19 NOW (@FOX19) <a href="https://twitter.com/FOX19/status/1382103555599953920?ref_src=twsrc%5Etfw">April 13, 2021</a></p></blockquote><p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><p>According to reports, Stallworth has been in police custody since Dec. 5.</p><p>The couple was charged with felony abuse of a corpse in late March and held on $100,000 bail, but prosecutors at the time indicated more serious charges could be coming.</p><div class="m"><picture><img class="aligncenter" src="https://a57.foxnews.com/static.foxnews.com/foxnews.com/content/uploads/2021/04/640/320/robert-robb.jpg?ve=1&amp;tl=1" alt="Robert Robb" /></picture></div><div class="caption"><p style="text-align: center;"><em><strong>Robert Robb <span class="copyright">(Hamilton County Sheriff&#8217;s Office)</span></strong></em></p></div><p><span style="font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen-Sans, Ubuntu, Cantarell, 'Helvetica Neue', sans-serif;">No new charges had been filed against Robb as of Wednesday evening.</span></p><p><span style="font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen-Sans, Ubuntu, Cantarell, 'Helvetica Neue', sans-serif;">Marcus Allen, the victim’s father, told </span><a style="font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen-Sans, Ubuntu, Cantarell, 'Helvetica Neue', sans-serif;" href="https://www.fox19.com/2021/04/13/mother-faces-murder-charge-death-son-year-old-dominic-allen/" target="_blank" rel="noopener">FOX19NOW</a><span style="font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen-Sans, Ubuntu, Cantarell, 'Helvetica Neue', sans-serif;"> that his son’s body may have shown signs of torture – a heinous act he had trouble understanding.</span></p><p><span style="font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen-Sans, Ubuntu, Cantarell, 'Helvetica Neue', sans-serif;">He gave the station a message for his son’s alleged killers.</span></p><p><span style="font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen-Sans, Ubuntu, Cantarell, 'Helvetica Neue', sans-serif;">&#8220;You all will get what you all got coming to you,&#8221; he said. &#8220;You all didn’t just take away my child. You took away the gift that God gave me. You took away my daughter’s best friend. You took away the nephew of all of my sisters and brothers. You all took him away from all of the people who loved him&#8230; and for what?&#8221;</span></p><p><span style="font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen-Sans, Ubuntu, Cantarell, 'Helvetica Neue', sans-serif;">Stallworth has a plea hearing on April 28.</span></p></div><div class="fb-comments" data-href="https://www.lawofficer.com/ohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes/" data-numposts="10" data-colorscheme="dark" data-order-by="social" data-mobile=true></div><style>.fb_iframe_widget_fluid_desktop iframe{width:100%!important}</style><br /><div class='heateorSssClear'></div><div class='heateor_sss_sharing_container heateor_sss_horizontal_sharing' heateor-sss-data-href='https://www.lawofficer.com/ohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes/'><div class='heateor_sss_sharing_title' style="font-weight:bold">Share and speak up for justice, law &amp; order...</div><ul class="heateor_sss_sharing_ul"><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Facebook" Title="Facebook" class="heateorSssSharing heateorSssFacebookBackground" onclick='heateorSssPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssFacebookSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Facebook Messenger" Title="Facebook Messenger" class="heateorSssSharing heateorSssFacebookMessengerBackground" onclick='heateorSssPopup("https://www.facebook.com/dialog/send?app_id=1904103319867886&display=popup&link=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F&redirect_uri=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssFacebookMessengerSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Instagram" Title="Instagram" class="heateorSssSharing heateorSssInstagramBackground"><a href="https://www.instagram.com/@lawofficeracademy" rel="nofollow noopener" target="_blank"><ss style="display:block;" class="heateorSssSharingSvg heateorSssInstagramSvg"></ss></a></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Twitter" Title="Twitter" class="heateorSssSharing heateorSssTwitterBackground" onclick='heateorSssPopup("http://twitter.com/intent/tweet?via=lawofficer&text=Ohio%20mother%20charged%20with%20murder%20after%20son%27s%20decomposing%20body%20found%20under%20pile%20of%20clothes&url=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssTwitterSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Parler" Title="Parler" class="heateorSssSharing heateorSssParlerBackground" onclick='heateorSssPopup("https://parler.com/new-post?message=Ohio%20mother%20charged%20with%20murder%20after%20son%27s%20decomposing%20body%20found%20under%20pile%20of%20clothes&url=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssParlerSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Email" Title="Email" class="heateorSssSharing heateorSssEmailBackground" onclick="window.open('mailto:?subject=' + decodeURIComponent('Ohio%20mother%20charged%20with%20murder%20after%20son%27s%20decomposing%20body%20found%20under%20pile%20of%20clothes' ).replace('&', '%26') + '&body=' + decodeURIComponent('https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F' ), '_blank')"><ss style="display:block" class="heateorSssSharingSvg heateorSssEmailSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Mendeley" Title="Mendeley" class="heateorSssSharing heateorSssMendeleyBackground" onclick='heateorSssPopup("https://www.mendeley.com/sign-in/")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssMendeleySvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Linkedin" Title="Linkedin" class="heateorSssSharing heateorSssLinkedinBackground" onclick='heateorSssPopup("http://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F&title=Ohio%20mother%20charged%20with%20murder%20after%20son%27s%20decomposing%20body%20found%20under%20pile%20of%20clothes")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssLinkedinSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Reddit" Title="Reddit" class="heateorSssSharing heateorSssRedditBackground" onclick='heateorSssPopup("http://reddit.com/submit?url=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F&title=Ohio%20mother%20charged%20with%20murder%20after%20son%27s%20decomposing%20body%20found%20under%20pile%20of%20clothes")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssRedditSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:48px;height:28px;" alt="Gab" Title="Gab" class="heateorSssSharing heateorSssGabBackground" onclick='heateorSssPopup("https://gab.com/compose?url=https%3A%2F%2Fwww.lawofficer.com%2Fohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes%2F&text=Ohio%20mother%20charged%20with%20murder%20after%20son%27s%20decomposing%20body%20found%20under%20pile%20of%20clothes")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssGabSvg"></ss></i></li></ul><div class="heateorSssClear"></div></div><div class='heateorSssClear'></div></div></div></div><div class='jeg_custom_tag_wrapper  '><div class="jeg_post_tags">
<span>Tags:</span> <a href="https://www.lawofficer.com/tag/cincinnati/" rel="tag">cincinnati</a><a href="https://www.lawofficer.com/tag/dominic-allen/" rel="tag">Dominic Allen</a><a href="https://www.lawofficer.com/tag/hamilton-county/" rel="tag">Hamilton County</a><a href="https://www.lawofficer.com/tag/kenya-stallworth/" rel="tag">Kenya Stallworth</a><a href="https://www.lawofficer.com/tag/ohio/" rel="tag">ohio</a><a href="https://www.lawofficer.com/tag/robert-robb/" rel="tag">Robert Robb</a></div></div><div class="vc_empty_space" style="height: 20px"><span class="vc_empty_space_inner"></span></div><div class='jeg_custom_author_wrapper jnews_author_box_container jnews_module_116522_7_6078506bef195   '><div class="jeg_authorbox"><div class="jeg_author_image">
<img alt='Law Officer' src='https://www.lawofficer.com/wp-content/uploads/2021/01/cropped-lawofficer-facebook-b-w-150x150.png' srcset='https://www.lawofficer.com/wp-content/uploads/2021/01/cropped-lawofficer-facebook-b-w-180x180.png 2x' class='avatar avatar-80 photo' height='80' width='80' loading='lazy' /></div><div class="jeg_author_content"><h3 class="jeg_author_name">
<a href="https://www.lawofficer.com/author/lawofficer/">
Law Officer </a></h3><p class="jeg_author_desc">
Law Officer is the only major law enforcement publication and website owned and operated by law enforcement—for law enforcement and supporters of justice, law, and order. This unique facet makes Law Officer much more than just a publishing company, but a true advocate for the law enforcement profession.</p><div class="jeg_author_socials">
<a target='_blank' href='https://www.facebook.com/lawofficer/' class='facebook'><i class='fa fa-facebook-official'></i> </a>
<a target='_blank' href='https://twitter.com/lawofficer' class='twitter'><i class='fa fa-twitter'></i> </a></div></div></div></div><div class="wpb_single_image wpb_content_element vc_align_center"><figure class="wpb_wrapper vc_figure">
<a href="https://defendtheheroes.com/law-officer/" target="_self" class="vc_single_image-wrapper   vc_box_border_grey"><img class="vc_single_image-img " src="https://www.lawofficer.com/wp-content/uploads/2021/01/cropped-lawofficer-facebook-b-w-240x240.png" width="240" height="240" alt="Law Officer Badge Blue" title="Law Officer Badge Blue" /></a></figure></div><h2 style="text-align: center;font-family:Roboto Condensed;font-weight:700;font-style:normal" class="vc_custom_heading"><a href="https://defendtheheroes.com/law-officer/" target="_blank">Donate &amp; Help Support Law Officer</a></h2><div class="wpb_text_column wpb_content_element "><div class="wpb_wrapper"><h3 style="text-align: center;"><strong><a href="https://defendtheheroes.com/law-officer/" target="_blank" rel="noopener">Donate now and help support justice, law &amp; order</a><br />
</strong>Your donation is tax-deductible.</h3></div></div><div class="vc_empty_space" style="height: 32px"><span class="vc_empty_space_inner"></span></div><div class='jnews_related_post_container jeg_custom_related_wrapper  '><div class="jeg_postblock_21 jeg_postblock jeg_module_hook jeg_pagination_loadmore jeg_col_2o3 jnews_module_116522_9_6078506befec9   " data-unique="jnews_module_116522_9_6078506befec9"><div class="jeg_block_heading jeg_block_heading_5 jeg_subcat_right"><h3 class="jeg_block_title"><span>Related<strong> Posts</strong></span></h3></div><div class="jeg_block_container"><div class="jeg_posts jeg_load_more_flag"><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/ohio-police-has-new-weapon-against-crime-anonymous-cards/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-23-at-8.13.06-PM-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-23-at-8.13.06-PM-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-23-at-8.13.06-PM-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-23-at-8.13.06-PM-750x536.png 750w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="1630" data-full-height="778" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/ohio-police-has-new-weapon-against-crime-anonymous-cards/">Ohio police has new weapon against crime: anonymous cards</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/ohio-police-has-new-weapon-against-crime-anonymous-cards/"><i class="fa fa-clock-o"></i> March 23, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/ohio-police-has-new-weapon-against-crime-anonymous-cards/"><i class="fa fa-eye"></i> 1.9k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/body-of-missing-ohio-woman-found-in-trunk-of-car/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/03/Missing-Woman-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="missing Ohio woman" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/03/Missing-Woman-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/03/Missing-Woman-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/03/Missing-Woman-750x536.png 750w, https://www.lawofficer.com/wp-content/uploads/2021/03/Missing-Woman-1140x815.png 1140w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="640" data-full-height="408" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/body-of-missing-ohio-woman-found-in-trunk-of-car/">Body of missing Ohio woman found in trunk of car</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/body-of-missing-ohio-woman-found-in-trunk-of-car/"><i class="fa fa-clock-o"></i> March 16, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/body-of-missing-ohio-woman-found-in-trunk-of-car/"><i class="fa fa-eye"></i> 2.8k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/cleveland-democrat-indicted-after-allegedly-stealing-127000-from-city/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-05-at-1.26.16-AM-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-05-at-1.26.16-AM-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-05-at-1.26.16-AM-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-05-at-1.26.16-AM-750x536.png 750w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="1056" data-full-height="600" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/cleveland-democrat-indicted-after-allegedly-stealing-127000-from-city/">Cleveland democrat indicted after allegedly stealing $127,000 from city</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/cleveland-democrat-indicted-after-allegedly-stealing-127000-from-city/"><i class="fa fa-clock-o"></i> March 5, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/cleveland-democrat-indicted-after-allegedly-stealing-127000-from-city/"><i class="fa fa-eye"></i> 2.8k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/watch-man-greets-ohio-deputies-with-gunfire-during-wellness-check/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/03/Warren-County-Sheriffs-Office-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="Ohio deputies" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/03/Warren-County-Sheriffs-Office-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/03/Warren-County-Sheriffs-Office-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/03/Warren-County-Sheriffs-Office-750x536.png 750w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="640" data-full-height="355" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/watch-man-greets-ohio-deputies-with-gunfire-during-wellness-check/">WATCH: Man greets Ohio deputies with gunfire during wellness check</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/watch-man-greets-ohio-deputies-with-gunfire-during-wellness-check/"><i class="fa fa-clock-o"></i> March 4, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/watch-man-greets-ohio-deputies-with-gunfire-during-wellness-check/"><i class="fa fa-eye"></i> 4k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/detroit-police-shoot-man-wanted-in-triple-homicide/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/03/Triple-murder-suspect-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="Detroit police" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/03/Triple-murder-suspect-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/03/Triple-murder-suspect-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/03/Triple-murder-suspect-750x536.png 750w, https://www.lawofficer.com/wp-content/uploads/2021/03/Triple-murder-suspect-1140x815.png 1140w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="640" data-full-height="366" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/detroit-police-shoot-man-wanted-in-triple-homicide/">Detroit police shoot man wanted in triple homicide</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/detroit-police-shoot-man-wanted-in-triple-homicide/"><i class="fa fa-clock-o"></i> March 1, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/detroit-police-shoot-man-wanted-in-triple-homicide/"><i class="fa fa-eye"></i> 2.2k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/ohio-mother-boyfriend-charged-in-killing-of-6-year-old-son/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-01-at-10.33.52-AM-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="Ohio mother" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-01-at-10.33.52-AM-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-01-at-10.33.52-AM-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-01-at-10.33.52-AM-750x536.png 750w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="640" data-full-height="330" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/ohio-mother-boyfriend-charged-in-killing-of-6-year-old-son/">Ohio mother, boyfriend charged in killing of 6-year-old son</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/ohio-mother-boyfriend-charged-in-killing-of-6-year-old-son/"><i class="fa fa-clock-o"></i> March 1, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/ohio-mother-boyfriend-charged-in-killing-of-6-year-old-son/"><i class="fa fa-eye"></i> 2.8k </a></div></div></div></article></div><div class='module-overlay'><div class='preloader_type preloader_dot'><div class="module-preloader jeg_preloader dot">
<span></span><span></span><span></span></div><div class="module-preloader jeg_preloader circle"><div class="jnews_preloader_circle_outer"><div class="jnews_preloader_circle_inner"></div></div></div><div class="module-preloader jeg_preloader square"><div class="jeg_square"><div class="jeg_square_inner"></div></div></div></div></div></div><div class="jeg_block_navigation"><div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div><div class="jeg_block_loadmore ">
<a href="#" class='' data-load='Load More' data-loading='Loading...'> Load More</a></div></div> <script>var jnews_module_116522_9_6078506befec9={"header_icon":"","first_title":"Related","second_title":" Posts","url":"","header_type":"heading_5","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"6","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":116522,"include_category":"","exclude_category":"","include_author":"","include_tag":"2112,17354,17355,17352,438,17353","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","force_normal_image_load":"","pagination_mode":"loadmore","pagination_nextprev_showtext":"","pagination_number_post":"6","pagination_scroll_limit":"3","boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","excerpt_length":"16","paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_21"}</script> </div></div><div class="vc_empty_space" style="height: 32px"><span class="vc_empty_space_inner"></span></div><div class="wpb_single_image wpb_content_element vc_align_center"><figure class="wpb_wrapper vc_figure">
<a href="https://www.amazon.com/Courageous-Police-Leader-Survival-Combating/dp/1733160590/ref=sr_1_1?dchild=1&amp;keywords=courageous+police&amp;qid=1614209565&amp;sr=8-1" target="_blank" class="vc_single_image-wrapper   vc_box_border_grey"><img width="970" height="180" src="https://www.lawofficer.com/wp-content/uploads/2020/01/lg-courageous-police-leader-banner.png" class="vc_single_image-img attachment-full" alt="Book: The Courageous Police Leader" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2020/01/lg-courageous-police-leader-banner.png 970w, https://www.lawofficer.com/wp-content/uploads/2020/01/lg-courageous-police-leader-banner-300x56.png 300w, https://www.lawofficer.com/wp-content/uploads/2020/01/lg-courageous-police-leader-banner-768x143.png 768w, https://www.lawofficer.com/wp-content/uploads/2020/01/lg-courageous-police-leader-banner-750x139.png 750w" sizes="(max-width: 970px) 100vw, 970px" data-full-width="970" data-full-height="180" /></a></figure></div><div class="vc_empty_space" style="height: 32px"><span class="vc_empty_space_inner"></span></div><div class="jeg_postblock_21 jeg_postblock jeg_module_hook jeg_pagination_loadmore jeg_col_2o3 jnews_module_116522_10_6078506c002db   " data-unique="jnews_module_116522_10_6078506c002db"><div class="jeg_block_heading jeg_block_heading_5 jeg_subcat_right"><h3 class="jeg_block_title"><span>Latest Articles</span></h3></div><div class="jeg_block_container"><div class="jeg_posts jeg_load_more_flag"><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/derek-chauvin-will-not-testify-in-his-defense/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/04/Screen-Shot-2021-04-15-at-9.22.42-AM-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="Derek Chauvin" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/04/Screen-Shot-2021-04-15-at-9.22.42-AM-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/04/Screen-Shot-2021-04-15-at-9.22.42-AM-350x250.png 350w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="640" data-full-height="342" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/derek-chauvin-will-not-testify-in-his-defense/">Derek Chauvin will not testify in his defense</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/derek-chauvin-will-not-testify-in-his-defense/"><i class="fa fa-clock-o"></i> April 15, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/derek-chauvin-will-not-testify-in-his-defense/"><i class="fa fa-eye"></i> 1.1k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/ohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/04/Kenya-Stallworth-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="Ohio mother" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/04/Kenya-Stallworth-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/04/Kenya-Stallworth-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/04/Kenya-Stallworth-750x536.png 750w, https://www.lawofficer.com/wp-content/uploads/2021/04/Kenya-Stallworth-1140x815.png 1140w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="640" data-full-height="360" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/ohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes/">Ohio mother charged with murder after son&#8217;s decomposing body found under pile of clothes</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/ohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes/"><i class="fa fa-clock-o"></i> April 15, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/ohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes/"><i class="fa fa-eye"></i> 1.6k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/democrats-set-to-unveil-plan-to-pack-supreme-court/"><div class="thumbnail-container  size-715 "><img width="115" height="86" src="https://www.lawofficer.com/wp-content/uploads/2017/05/supremecourt-scaled.jpg" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2017/05/supremecourt-scaled.jpg 2560w, https://www.lawofficer.com/wp-content/uploads/2017/05/supremecourt-600x450.jpg 600w, https://www.lawofficer.com/wp-content/uploads/2017/05/supremecourt-300x225.jpg 300w, https://www.lawofficer.com/wp-content/uploads/2017/05/supremecourt-768x576.jpg 768w, https://www.lawofficer.com/wp-content/uploads/2017/05/supremecourt-1024x768.jpg 1024w, https://www.lawofficer.com/wp-content/uploads/2017/05/supremecourt-760x570.jpg 760w, https://www.lawofficer.com/wp-content/uploads/2017/05/supremecourt-380x285.jpg 380w, https://www.lawofficer.com/wp-content/uploads/2017/05/supremecourt-253x189.jpg 253w" sizes="(max-width: 115px) 100vw, 115px" data-full-width="2560" data-full-height="1920" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/democrats-set-to-unveil-plan-to-pack-supreme-court/">Democrats set to unveil plan to pack Supreme Court</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/democrats-set-to-unveil-plan-to-pack-supreme-court/"><i class="fa fa-clock-o"></i> April 15, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/democrats-set-to-unveil-plan-to-pack-supreme-court/"><i class="fa fa-eye"></i> 1.3k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/forensic-pathologist-takes-stand-in-chauvins-defense/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/04/Defense-pathologist-Dr.-Fowler-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="forensic pathologist" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/04/Defense-pathologist-Dr.-Fowler-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/04/Defense-pathologist-Dr.-Fowler-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/04/Defense-pathologist-Dr.-Fowler-750x536.png 750w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="640" data-full-height="358" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/forensic-pathologist-takes-stand-in-chauvins-defense/">Forensic pathologist takes stand in Chauvin&#8217;s defense</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/forensic-pathologist-takes-stand-in-chauvins-defense/"><i class="fa fa-clock-o"></i> April 14, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/forensic-pathologist-takes-stand-in-chauvins-defense/"><i class="fa fa-eye"></i> 2.1k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/brooklyn-center-mayor-says-police-do-not-need-guns-on-traffic-stops/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/04/Mayor-Elliott-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="Brooklyn Center mayor" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/04/Mayor-Elliott-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/04/Mayor-Elliott-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/04/Mayor-Elliott-750x536.png 750w, https://www.lawofficer.com/wp-content/uploads/2021/04/Mayor-Elliott-1140x815.png 1140w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="640" data-full-height="404" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/brooklyn-center-mayor-says-police-do-not-need-guns-on-traffic-stops/">Brooklyn Center mayor absurdly claims police do not need guns on traffic stops</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/brooklyn-center-mayor-says-police-do-not-need-guns-on-traffic-stops/"><i class="fa fa-clock-o"></i> April 14, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/brooklyn-center-mayor-says-police-do-not-need-guns-on-traffic-stops/"><i class="fa fa-eye"></i> 2.9k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/doj-will-not-pursue-charges-against-capitol-police-officer-involved-in-ashli-babbitts-death/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/01/Air-Force-Vet-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="USAF veteran" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/01/Air-Force-Vet-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/01/Air-Force-Vet-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/01/Air-Force-Vet-750x536.png 750w, https://www.lawofficer.com/wp-content/uploads/2021/01/Air-Force-Vet-1140x815.png 1140w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="640" data-full-height="398" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/doj-will-not-pursue-charges-against-capitol-police-officer-involved-in-ashli-babbitts-death/">DOJ will not pursue charges against Capitol police officer involved in Ashli Babbitt&#8217;s death</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/doj-will-not-pursue-charges-against-capitol-police-officer-involved-in-ashli-babbitts-death/"><i class="fa fa-clock-o"></i> April 14, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/doj-will-not-pursue-charges-against-capitol-police-officer-involved-in-ashli-babbitts-death/"><i class="fa fa-eye"></i> 2.6k </a></div></div></div></article></div><div class='module-overlay'><div class='preloader_type preloader_dot'><div class="module-preloader jeg_preloader dot">
<span></span><span></span><span></span></div><div class="module-preloader jeg_preloader circle"><div class="jnews_preloader_circle_outer"><div class="jnews_preloader_circle_inner"></div></div></div><div class="module-preloader jeg_preloader square"><div class="jeg_square"><div class="jeg_square_inner"></div></div></div></div></div></div><div class="jeg_block_navigation"><div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div><div class="jeg_block_loadmore ">
<a href="#" class='' data-load='Load More' data-loading='Loading...'> Load More</a></div></div> <script>var jnews_module_116522_10_6078506c002db={"header_icon":"","first_title":"Latest Articles","second_title":"","url":"","header_type":"heading_5","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"6","post_offset":"0","unique_content":"disable","include_post":"","exclude_post":"","include_category":"","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","force_normal_image_load":"","pagination_mode":"loadmore","pagination_nextprev_showtext":"","pagination_number_post":"6","pagination_scroll_limit":0,"boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","compatible_column_notice":"","paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_21"}</script> </div><div class="vc_empty_space" style="height: 32px"><span class="vc_empty_space_inner"></span></div><div class="wpb_single_image wpb_content_element vc_align_left"><figure class="wpb_wrapper vc_figure">
<a href="https://www.liberty.edu/lp/first-responder/?acode=D00060&amp;utm_source=lawofficer&amp;utm_medium=website&amp;utm_campaign=flyer" target="_blank" class="vc_single_image-wrapper   vc_box_border_grey"><img width="728" height="90" src="https://www.lawofficer.com/wp-content/uploads/2021/01/Liberty-University-Ad-47846-LUO-Q3-Banner-Ads_CriminalJustice-728-x-90.jpg" class="vc_single_image-img attachment-full" alt="" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/01/Liberty-University-Ad-47846-LUO-Q3-Banner-Ads_CriminalJustice-728-x-90.jpg 728w, https://www.lawofficer.com/wp-content/uploads/2021/01/Liberty-University-Ad-47846-LUO-Q3-Banner-Ads_CriminalJustice-728-x-90-300x37.jpg 300w" sizes="(max-width: 728px) 100vw, 728px" data-full-width="728" data-full-height="90" /></a></figure></div><div class="wpb_text_column wpb_content_element "><div class="wpb_wrapper"><p><strong>Liberty University offers affordable tuition <a href="http://luonline.com/lawofficer" target="_blank" rel="noopener">and a 25% discount for law officers and first responders.</a></strong></p></div></div><div class="vc_empty_space" style="height: 32px"><span class="vc_empty_space_inner"></span></div><div class="row vc_row wpb_row vc_inner vc_row-fluid"><div class="wpb_column vc_column_container vc_col-sm-9"><div class="jeg_wrapper "><div class="wpb_wrapper"><div class="wpb_text_column wpb_content_element "><div class="wpb_wrapper"><h3 style="text-align: left;"><strong>Follow your Law Officer Local Network:</strong></h3><ul><li><strong><a href="/illinois">Illinois</a></strong></li><li><strong><a href="/minneapolis">Minneapolis, MN</a></strong></li><li><strong><a href="https://www.lawofficer.com/nyc/">New York, NY</a></strong></li><li><strong><a href="/tulsa">Tulsa, OK</a></strong></li><li><strong><a href="/wauwatosa">Wauwatosa, WI</a></strong></li></ul><p>More coming soon. Follow the news related justice, law, and order in your local area—and stand up and speak out.</p></div></div></div></div></div></div></div></div><div class="wpb_column jeg_column vc_column_container vc_col-sm-4"><div class="jeg_wrapper wpb_wrapper"><div class="wpb_widgetised_column wpb_content_element"><div class="wpb_wrapper"><div class="widget_text widget  jeg_pb_boxed widget_custom_html" id="custom_html-9"><div class="textwidget custom-html-widget"><center><a href="https://defendtheheroes.com/law-officer/"><img src="https://www.lawofficer.com/wp-content/uploads/2021/01/cropped-lawofficer-facebook-b-w.png" width="160" height="160"></a>
<br><a href="https://defendtheheroes.com/law-officer/"><h2>Please donate and help support Law Officer</a></h2></center></div></div><div class="widget widget_jnews_module_block_21" id="jnews_module_block_21-2"><div class="jeg_postblock_21 jeg_postblock jeg_module_hook jeg_pagination_loadmore jeg_col_1o3 jnews_module_116522_11_6078506c0c073  normal " data-unique="jnews_module_116522_11_6078506c0c073"><div class="jeg_block_heading jeg_block_heading_5 jeg_subcat_right"><h3 class="jeg_block_title"><span>Must Read</span></h3></div><div class="jeg_block_container"><div class="jeg_posts jeg_load_more_flag"><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/officer-expresses-shock-after-shooting-combative-suspect-with-firearm-instead-of-taser/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/04/Minnesota-shooting-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="Officer expresses shock" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/04/Minnesota-shooting-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/04/Minnesota-shooting-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/04/Minnesota-shooting-750x536.png 750w, https://www.lawofficer.com/wp-content/uploads/2021/04/Minnesota-shooting-1140x808.png 1140w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="640" data-full-height="423" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/officer-expresses-shock-after-shooting-combative-suspect-with-firearm-instead-of-taser/">Officer expresses shock after shooting combative suspect with firearm instead of Taser</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/officer-expresses-shock-after-shooting-combative-suspect-with-firearm-instead-of-taser/"><i class="fa fa-clock-o"></i> April 12, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/officer-expresses-shock-after-shooting-combative-suspect-with-firearm-instead-of-taser/"><i class="fa fa-eye"></i> 12.5k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/qualified-immunity-is-an-endangered-species/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2020/02/Police-Lights-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="Texas police sergeant" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2020/02/Police-Lights-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2020/02/Police-Lights-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2020/02/Police-Lights-750x536.png 750w, https://www.lawofficer.com/wp-content/uploads/2020/02/Police-Lights-1140x815.png 1140w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="640" data-full-height="470" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/qualified-immunity-is-an-endangered-species/">Qualified immunity is an endangered species</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/qualified-immunity-is-an-endangered-species/"><i class="fa fa-clock-o"></i> April 2, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/qualified-immunity-is-an-endangered-species/"><i class="fa fa-eye"></i> 2.3k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/doj-quietly-acknowledges-there-was-no-sedition-at-the-us-capitol/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-30-at-8.07.26-AM-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="sedition charges" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-30-at-8.07.26-AM-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-30-at-8.07.26-AM-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-30-at-8.07.26-AM-750x536.png 750w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-30-at-8.07.26-AM-1140x815.png 1140w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="640" data-full-height="427" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/doj-quietly-acknowledges-there-was-no-sedition-at-the-us-capitol/">DOJ quietly acknowledges there was no sedition at the US Capitol</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/doj-quietly-acknowledges-there-was-no-sedition-at-the-us-capitol/"><i class="fa fa-clock-o"></i> March 30, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/doj-quietly-acknowledges-there-was-no-sedition-at-the-us-capitol/"><i class="fa fa-eye"></i> 150.6k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/criminals-are-duping-the-woke/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/02/protester-portland-wokeness-120x86.jpg" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="Source: Tito Texidor III, unsplash" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/02/protester-portland-wokeness-120x86.jpg 120w, https://www.lawofficer.com/wp-content/uploads/2021/02/protester-portland-wokeness-350x250.jpg 350w, https://www.lawofficer.com/wp-content/uploads/2021/02/protester-portland-wokeness-750x536.jpg 750w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="1200" data-full-height="800" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/criminals-are-duping-the-woke/">Duping the &#8216;woke&#8217;—a new kind of criminality in America</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/criminals-are-duping-the-woke/"><i class="fa fa-clock-o"></i> March 26, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/criminals-are-duping-the-woke/"><i class="fa fa-eye"></i> 4.4k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/asian-fighting-white-terror/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/03/asian-american-media-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="Source: bantersnaps, unsplash" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/03/asian-american-media-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/03/asian-american-media-300x214.png 300w, https://www.lawofficer.com/wp-content/uploads/2021/03/asian-american-media-2000x1428.png 2000w, https://www.lawofficer.com/wp-content/uploads/2021/03/asian-american-media-768x548.png 768w, https://www.lawofficer.com/wp-content/uploads/2021/03/asian-american-media-1536x1097.png 1536w, https://www.lawofficer.com/wp-content/uploads/2021/03/asian-american-media-2048x1463.png 2048w, https://www.lawofficer.com/wp-content/uploads/2021/03/asian-american-media-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/03/asian-american-media-750x536.png 750w, https://www.lawofficer.com/wp-content/uploads/2021/03/asian-american-media-1140x814.png 1140w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="2134" data-full-height="1524" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/asian-fighting-white-terror/">Are Asian-Americans victims of &#8216;white terror&#8217;—or the media?</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/asian-fighting-white-terror/"><i class="fa fa-clock-o"></i> March 21, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/asian-fighting-white-terror/"><i class="fa fa-eye"></i> 4.4k </a></div></div></div></article></div><div class='module-overlay'><div class='preloader_type preloader_dot'><div class="module-preloader jeg_preloader dot">
<span></span><span></span><span></span></div><div class="module-preloader jeg_preloader circle"><div class="jnews_preloader_circle_outer"><div class="jnews_preloader_circle_inner"></div></div></div><div class="module-preloader jeg_preloader square"><div class="jeg_square"><div class="jeg_square_inner"></div></div></div></div></div></div><div class="jeg_block_navigation"><div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div><div class="jeg_block_loadmore ">
<a href="#" class='' data-load='Load More' data-loading='Loading...'> Load More</a></div></div> <script>var jnews_module_116522_11_6078506c0c073={"header_icon":"","first_title":"Must Read","second_title":"","url":"","header_type":"heading_5","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"5","post_offset":"0","unique_content":"disable","include_post":"","exclude_post":"","include_category":"","exclude_category":"","include_author":"","include_tag":"13772","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","force_normal_image_load":"0","pagination_mode":"loadmore","pagination_nextprev_showtext":"0","pagination_number_post":"4","pagination_scroll_limit":"0","boxed":"0","boxed_shadow":"0","el_id":"","el_class":"","scheme":"normal","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"jnews_block_21"}</script> </div></div><div class="widget_text widget widget_custom_html" id="custom_html-8"><div class="jeg_block_heading jeg_block_heading_5 jnews_6078506c0f4e6"><h3 class="jeg_block_title"><span>Stand up &#038; speak out!</span></h3></div><div class="textwidget custom-html-widget"><b><h3 style="color: #1e73be;text-align: left;"><a style="color: #30ce7d;" href="https://gab.com/groups/29821">Gab with us—fight censorship!</a></h3></div></div><div class="widget widget_jnews_module_block_21" id="jnews_module_block_21-4"><div class="jeg_postblock_21 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 jnews_module_116522_12_6078506c0f5fb  normal " data-unique="jnews_module_116522_12_6078506c0f5fb"><div class="jeg_block_heading jeg_block_heading_5 jeg_subcat_right"><h3 class="jeg_block_title"><span>Most Popular</span></h3></div><div class="jeg_block_container"><div class="jeg_posts jeg_load_more_flag"><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/graphic-video-shows-deadly-encounter-between-nashville-officer-and-tennessee-woman/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-15-at-10.25.38-AM-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="Nashville officer" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-15-at-10.25.38-AM-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-15-at-10.25.38-AM-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-15-at-10.25.38-AM-750x536.png 750w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-15-at-10.25.38-AM-1140x808.png 1140w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="640" data-full-height="422" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/graphic-video-shows-deadly-encounter-between-nashville-officer-and-tennessee-woman/">Graphic video shows deadly encounter between Nashville officer and Tennessee woman</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/graphic-video-shows-deadly-encounter-between-nashville-officer-and-tennessee-woman/"><i class="fa fa-clock-o"></i> March 15, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/graphic-video-shows-deadly-encounter-between-nashville-officer-and-tennessee-woman/"><i class="fa fa-eye"></i> 221.1k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/new-mexico-state-police-release-horrifying-video-of-officers-murder/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/04/New-Mexico-Officer-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="New Mexico State Police" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/04/New-Mexico-Officer-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/04/New-Mexico-Officer-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/04/New-Mexico-Officer-750x536.png 750w, https://www.lawofficer.com/wp-content/uploads/2021/04/New-Mexico-Officer-1140x815.png 1140w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="640" data-full-height="357" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/new-mexico-state-police-release-horrifying-video-of-officers-murder/">New Mexico State Police release horrifying video of officer&#8217;s murder</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/new-mexico-state-police-release-horrifying-video-of-officers-murder/"><i class="fa fa-clock-o"></i> April 11, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/new-mexico-state-police-release-horrifying-video-of-officers-murder/"><i class="fa fa-eye"></i> 52.5k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/florida-man-reportedly-pulled-out-human-ears-when-questioned-about-grandfathers-murder/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-15-at-8.56.56-AM-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="ears" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-15-at-8.56.56-AM-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-15-at-8.56.56-AM-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-15-at-8.56.56-AM-750x536.png 750w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-15-at-8.56.56-AM-1140x815.png 1140w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="640" data-full-height="403" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/florida-man-reportedly-pulled-out-human-ears-when-questioned-about-grandfathers-murder/">Florida man reportedly pulled out human ears when questioned about grandfather&#8217;s murder</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/florida-man-reportedly-pulled-out-human-ears-when-questioned-about-grandfathers-murder/"><i class="fa fa-clock-o"></i> March 15, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/florida-man-reportedly-pulled-out-human-ears-when-questioned-about-grandfathers-murder/"><i class="fa fa-eye"></i> 71.4k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/doj-quietly-acknowledges-there-was-no-sedition-at-the-us-capitol/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-30-at-8.07.26-AM-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="sedition charges" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-30-at-8.07.26-AM-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-30-at-8.07.26-AM-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-30-at-8.07.26-AM-750x536.png 750w, https://www.lawofficer.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-30-at-8.07.26-AM-1140x815.png 1140w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="640" data-full-height="427" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/doj-quietly-acknowledges-there-was-no-sedition-at-the-us-capitol/">DOJ quietly acknowledges there was no sedition at the US Capitol</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/doj-quietly-acknowledges-there-was-no-sedition-at-the-us-capitol/"><i class="fa fa-clock-o"></i> March 30, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/doj-quietly-acknowledges-there-was-no-sedition-at-the-us-capitol/"><i class="fa fa-eye"></i> 150.6k </a></div></div></div></article><article class="jeg_post jeg_pl_sm format-standard"><div class="jeg_thumb">
<a href="https://www.lawofficer.com/chauvin-trial-drug-deal/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://www.lawofficer.com/wp-content/uploads/2021/04/Screen-Shot-2021-04-01-at-8.53.58-PM-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="" loading="lazy" srcset="https://www.lawofficer.com/wp-content/uploads/2021/04/Screen-Shot-2021-04-01-at-8.53.58-PM-120x86.png 120w, https://www.lawofficer.com/wp-content/uploads/2021/04/Screen-Shot-2021-04-01-at-8.53.58-PM-350x250.png 350w, https://www.lawofficer.com/wp-content/uploads/2021/04/Screen-Shot-2021-04-01-at-8.53.58-PM-750x536.png 750w, https://www.lawofficer.com/wp-content/uploads/2021/04/Screen-Shot-2021-04-01-at-8.53.58-PM-1140x815.png 1140w" sizes="(max-width: 120px) 100vw, 120px" data-full-width="1168" data-full-height="986" /></div></a></div><div class="jeg_postblock_content"><h3 class="jeg_post_title">
<a href="https://www.lawofficer.com/chauvin-trial-drug-deal/">Journalist: Derek Chauvin &#8216;will be acquitted&#8217;; alleged drug dealer invokes the Fifth Amendment</a></h3><div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.lawofficer.com/chauvin-trial-drug-deal/"><i class="fa fa-clock-o"></i> April 1, 2021</a></div><div class="jeg_meta_views"><a href="https://www.lawofficer.com/chauvin-trial-drug-deal/"><i class="fa fa-eye"></i> 86.6k </a></div></div></div></article></div><div class='module-overlay'><div class='preloader_type preloader_dot'><div class="module-preloader jeg_preloader dot">
<span></span><span></span><span></span></div><div class="module-preloader jeg_preloader circle"><div class="jnews_preloader_circle_outer"><div class="jnews_preloader_circle_inner"></div></div></div><div class="module-preloader jeg_preloader square"><div class="jeg_square"><div class="jeg_square_inner"></div></div></div></div></div></div><div class="jeg_block_navigation"><div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div></div> <script>var jnews_module_116522_12_6078506c0f5fb={"header_icon":"","first_title":"Most Popular","second_title":"","url":"","header_type":"heading_5","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"5","post_offset":"0","unique_content":"disable","include_post":"","exclude_post":"74316","include_category":"","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"popular_post_week","date_format":"default","date_format_custom":"Y\/m\/d","force_normal_image_load":"0","pagination_mode":"disable","pagination_nextprev_showtext":"0","pagination_number_post":"4","pagination_scroll_limit":"0","boxed":"0","boxed_shadow":"0","el_id":"","el_class":"","scheme":"normal","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"jnews_block_21"}</script> </div></div><div class="widget widget_categories" id="categories-3"><div class="jeg_block_heading jeg_block_heading_5 jnews_6078506c2fa5b"><h3 class="jeg_block_title"><span>More from Law Officer</span></h3></div><ul><li class="cat-item cat-item-36"><a href="https://www.lawofficer.com/category/archive/" title="News, analysis, and commentary from the past. A valuable resource for research and learning lessons from the past...">Archives</a> (12,812)</li><li class="cat-item cat-item-198"><a href="https://www.lawofficer.com/category/chaplain/" title="Insight, perspective, and advice from police chaplains throughout America. Keep faith and keep up with the heart, spirit, and soul of law enforcement.">Chaplain</a> (74)</li><li class="cat-item cat-item-15905"><a href="https://www.lawofficer.com/category/chauvin-trial/">Chauvin Trial</a> (13)</li><li class="cat-item cat-item-143"><a href="https://www.lawofficer.com/category/community-oriented-policing/" title="The latest news and commentary about community-oriented policing—including the challenges and triumphs. Stay informed with the latest developments and best practices for every rank and situation of community-oriented policing.">Community</a> (128)</li><li class="cat-item cat-item-12827"><a href="https://www.lawofficer.com/category/cop-humor/" title="The weirder wackier side of police work. Humor, satire, and parody from various Law Officer contributors...">Cop Humor</a> (15)</li><li class="cat-item cat-item-12759"><a href="https://www.lawofficer.com/category/crime-controversy/" title="News, analysis, and insights about recent crimes and controversies affecting law enforcement.">Crime &amp; Controversy</a> (127)</li><li class="cat-item cat-item-1801"><a href="https://www.lawofficer.com/category/editorial/" title="Standing up—and speaking out—for law enforcement. Law Officer Editorials focus on the controversial, the cowardly, and the complex issues affecting the law enforcement profession. Here, Law Officers contributors speak their minds, share their opinions, and draw the line for justice, law, and order.">Editorial</a> (458)</li><li class="cat-item cat-item-130"><a href="https://www.lawofficer.com/category/gear-technology/" title="The latest news, developments, and commentary about gear and technology for law enforcement and criminal investigations.">Gear &amp; Technology</a> (64)</li><li class="cat-item cat-item-124"><a href="https://www.lawofficer.com/category/investigations/" title="The latest news and opinions regarding crime and political investigations. Law Officer covers investigations underway locally and nationally.">Investigations</a> (2,430)</li><li class="cat-item cat-item-125"><a href="https://www.lawofficer.com/category/laws/" title="The latest news and analysis about laws and legal matters affecting law enforcement.">Laws &amp; Legal</a> (1,315)</li><li class="cat-item cat-item-126"><a href="https://www.lawofficer.com/category/leadership/" title="The rewarding—and the regrettable—sides of leadership. Law Officer provides news and commentary about &quot;what to do&quot; and &quot;what not to do&quot; when it comes to leadership in politics and policing.">Leadership</a> (477)</li><li class="cat-item cat-item-120"><a href="https://www.lawofficer.com/category/news/" title="No censorship here. Law Officer provides news, facts, and figures that matter to law enforcement. Unlike other news outlets, Law Officer draws upon a wide network of officers of every rank for perspective and validation of breaking news.">News</a> (5,994)</li><li class="cat-item cat-item-135"><a href="https://www.lawofficer.com/category/officer-down/" title="News and information about law enforcement officers who have been injured or killed.">Officer Down</a> (804)</li><li class="cat-item cat-item-12758"><a href="https://www.lawofficer.com/category/on-duty/" title="The latest news and developments affecting law enforcement work on duty.">On Duty</a> (88)</li><li class="cat-item cat-item-123"><a href="https://www.lawofficer.com/category/op-ed/" title="Opinions, analysis, and commentary written by contributors to Law Officer covering a variety of topics concerning law enforcement, crime, and society.">Op-ed</a> (600)</li><li class="cat-item cat-item-13351"><a href="https://www.lawofficer.com/category/reference/">Reference</a> (1)</li><li class="cat-item cat-item-129"><a href="https://www.lawofficer.com/category/tactics/" title="The latest developments and time-proven tactics for law enforcement and corrections. Stay informed of best practices to avoid complacency, improve officer safety, and stay ahead—and stay safe.">Tactics</a> (405)</li></ul></div><div class="widget_text widget widget_custom_html" id="custom_html-7"><div class="jeg_block_heading jeg_block_heading_5 jnews_6078506c30464"><h3 class="jeg_block_title"><span>LA Police Gear</span></h3></div><div class="textwidget custom-html-widget"><a href="https://www.avantlink.com/click.php?tt=cl&amp;merchant_id=1a244b4d-1f4f-4b24-8f88-172c21e5daae&amp;website_id=2e5ca22b-a99b-4d48-81e5-7878f903d213&amp;url=https%3A%2F%2Flapolicegear.com%2F"><img src="https://www.lawofficer.com/wp-content/uploads/2021/02/LA-Police-Gear.png" /><img style="visibility: hidden; border: none !important; margin: 0 !important;" src="https://www.avantlink.com/tpv/1a244b4d-1f4f-4b24-8f88-172c21e5daae/0/d2b2cb81-129d-4a00-bba5-02ed32963745/2e5ca22b-a99b-4d48-81e5-7878f903d213/-/cl/image.png" alt="" width="0" height="0" /> </a></div></div></div></div></div></div></div></div><div class="jnews_popup_post_container"></div></div></div></div></div><div id="post-body-class" class="post-template-default single single-post postid-116522 single-format-standard wp-embed-responsive jeg_toggle_dark jnews jsc_normal wpb-js-composer js-comp-ver-6.6.0 vc_responsive"></div></div><div class="post-ajax-overlay"><div class="preloader_type preloader_dot"><div class="newsfeed_preloader jeg_preloader dot">
<span></span><span></span><span></span></div><div class="newsfeed_preloader jeg_preloader circle"><div class="jnews_preloader_circle_outer"><div class="jnews_preloader_circle_inner"></div></div></div><div class="newsfeed_preloader jeg_preloader square"><div class="jeg_square"><div class="jeg_square_inner"></div></div></div></div></div></div><div class="footer-holder" id="footer" data-id="footer"><div class="jeg_footer jeg_footer_sidecontent dark"><div class="jeg_footer_container jeg_container"><div class="jeg_footer_content"><div class="container"><div class="row"><div class="jeg_footer_primary clearfix"><div class="col-md-2 footer_column"><div class="footer_widget widget_about"><div class="jeg_about">
<a href="https://www.lawofficer.com/" class="footer_logo">
<img class='jeg_logo_img' src="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png" srcset="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png 1x, https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png 2x" alt="Law Officer" data-light-src="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png" data-light-srcset="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png 1x, https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png 2x" data-dark-src="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png" data-dark-srcset="https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png 1x, https://www.lawofficer.com/wp-content/uploads/2021/01/law-officer-logo-wg.png 2x"> </a><p class="copyright"> © 2021 LawOfficer.com</p></div></div></div><div class="col-md-7 col-sm-8 footer_column"><div class="footer_widget widget_nav_menu"><div class="jeg_footer_heading jeg_footer_heading_2"><h3 class="jeg_footer_title menu-title"><span>LawOfficer.com</span></h3></div><ul class="jeg_menu_footer"><li id="menu-item-60226" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-60226"><a href="https://www.lawofficer.com/">Home</a></li><li id="menu-item-90619" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-90619"><a href="/about/">About</a></li><li id="menu-item-90620" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-90620"><a href="/advertise/">Advertise</a></li><li id="menu-item-90617" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-90617"><a href="/privacy-policy">Privacy Policy</a></li><li id="menu-item-90621" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-90621"><a href="/corrections/">Corrections</a></li><li id="menu-item-90618" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-90618"><a href="/contact/">Contact</a></li></ul></div></div><div class="col-md-3 col-sm-4 footer_column"><div class="jeg_footer_heading jeg_footer_heading_2"><h3 class="jeg_footer_title social-title"><span>Speak up for justice, law &amp; order</span></h3></div><div class="socials_widget nobg">
<a href="https://www.facebook.com/LawOfficer" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://www.linkedin.com/groups/1786754/  " target='_blank' class="jeg_linkedin"><i class="fa fa-linkedin"></i> </a><a href="https://www.instagram.com/lawofficeracademy/" target='_blank' class="jeg_instagram"><i class="fa fa-instagram"></i> </a><a href="https://twitter.com/lawofficer" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.lawofficer.com/feed" target='_blank' class="jeg_rss"><i class="fa fa-rss"></i> </a></div></div></div></div></div></div></div></div></div><div class="jscroll-to-top">
<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a></div></div><div id="jeg_off_canvas" class="normal">
<a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a><div class="jeg_bg_overlay"></div><div class="jeg_mobile_wrapper"><div class="nav_wrap"><div class="item_main"><div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round">
<a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a><form action="https://www.lawofficer.com/" method="get" class="jeg_search_form" target="_top">
<input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
<button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button></form><div class="jeg_search_result jeg_search_hide with_result"><div class="search-result-wrapper"></div><div class="search-link search-noresult">
No Result</div><div class="search-link search-all-button">
<i class="fa fa-search"></i> View All Result</div></div></div><div class="jeg_aside_item"><ul class="jeg_mobile_menu"><li id="menu-item-59938" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-59938"><a href="https://www.lawofficer.com/">Home</a></li><li id="menu-item-60143" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60143"><a href="https://www.lawofficer.com/about/">About Us</a></li><li id="menu-item-61385" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61385"><a href="https://www.lawofficer.com/advertise/">Advertise</a></li><li id="menu-item-60144" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60144"><a href="https://www.lawofficer.com/contact/">Contact Us</a></li><li id="menu-item-93328" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-93328"><a href="https://www.lawofficer.com/network/">Law Officer Networks</a><ul class="sub-menu"><li id="menu-item-93326" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93326"><a href="https://www.lawofficer.com/illinois/">Illinois Network</a></li><li id="menu-item-93327" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93327"><a href="https://www.lawofficer.com/minneapolis/">Minneapolis Network</a></li><li id="menu-item-95635" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-95635"><a href="https://www.lawofficer.com/nyc/">NYC Network</a></li><li id="menu-item-93330" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93330"><a href="https://www.lawofficer.com/tulsa/">Tulsa Network</a></li><li id="menu-item-93329" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-93329"><a href="https://www.lawofficer.com/wauwatosa/">Wauwatosa Network</a></li><li id="menu-item-94296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-94296"><a href="/network">Join the Network!</a></li></ul></li></ul></div></div><div class="item_bottom"><div class="jeg_aside_item socials_widget rounded">
<a href="https://www.facebook.com/LawOfficer" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://www.linkedin.com/groups/1786754/  " target='_blank' class="jeg_linkedin"><i class="fa fa-linkedin"></i> </a><a href="https://www.instagram.com/lawofficeracademy/" target='_blank' class="jeg_instagram"><i class="fa fa-instagram"></i> </a><a href="https://twitter.com/lawofficer" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.lawofficer.com/feed" target='_blank' class="jeg_rss"><i class="fa fa-rss"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright"><p>© 2021 LawOfficer.com</p></div></div></div></div></div><script type="text/javascript">var jfla=["view_counter"]</script><div class="pswp" tabindex="-1" role="dialog" aria-hidden="true"><div class="pswp__bg"></div><div class="pswp__scroll-wrap"><div class="pswp__container"><div class="pswp__item"></div><div class="pswp__item"></div><div class="pswp__item"></div></div><div class="pswp__ui pswp__ui--hidden"><div class="pswp__top-bar"><div class="pswp__counter"></div>
<button class="pswp__button pswp__button--close" title="Close (Esc)"></button>
<button class="pswp__button pswp__button--share" title="Share"></button>
<button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button>
<button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button><div class="pswp__preloader"><div class="pswp__preloader__icn"><div class="pswp__preloader__cut"><div class="pswp__preloader__donut"></div></div></div></div></div><div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap"><div class="pswp__share-tooltip"></div></div>
<button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)">
</button>
<button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)">
</button><div class="pswp__caption"><div class="pswp__caption__center"></div></div></div></div></div><div id="fb-root"></div> <script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src='https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.10&appId=581238329089601';fjs.parentNode.insertBefore(js,fjs)}(document,'script','facebook-jssdk'))</script>
<script type="text/javascript">jQuery(document).ready(function(){jQuery('.description').before('<span><!--INFOLINKS_OFF--></span>');jQuery('.description').after('<span><!--INFOLINKS_ON--></span>');jQuery('#headerimg').before('<span><!--INFOLINKS_OFF--></span>');jQuery('#headerimg').after('<span><!--INFOLINKS_ON--></span>');jQuery('h1').before('<span><!--INFOLINKS_OFF--></span>');jQuery('h1').after('<span><!--INFOLINKS_ON--></span>');jQuery('h1').before('<span><!--INFOLINKS_OFF--></span>');jQuery('h1').after('<span><!--INFOLINKS_ON--></span>')})</script> <script type="text/javascript">var infolinks_pid=3289635;var infolinks_plugin_version="WP_3.2.3";var infolinks_resources="https://resources.infolinks.com/js"</script> <script type="text/javascript" src="https://resources.infolinks.com/js/infolinks_main.js"></script> <div class="jeg_read_progress_wrapper"></div><script type="text/html" id="wpb-modifications"></script><style type="text/css" media="all">@font-face{font-family:'Roboto Condensed';font-style:italic;font-weight:300;font-display:swap;src:url(https://fonts.gstatic.com/s/robotocondensed/v19/ieVg2ZhZI2eCN5jzbjEETS9weq8-19eDpCEobdNf.woff) format('woff')}@font-face{font-family:'Roboto Condensed';font-style:italic;font-weight:400;font-display:swap;src:url(https://fonts.gstatic.com/s/robotocondensed/v19/ieVj2ZhZI2eCN5jzbjEETS9weq8-19eLDwM7.woff) format('woff')}@font-face{font-family:'Roboto Condensed';font-style:italic;font-weight:700;font-display:swap;src:url(https://fonts.gstatic.com/s/robotocondensed/v19/ieVg2ZhZI2eCN5jzbjEETS9weq8-19eDtCYobdNf.woff) format('woff')}@font-face{font-family:'Roboto Condensed';font-display:block;font-style:normal;font-weight:300;font-display:swap;src:url(https://fonts.gstatic.com/s/robotocondensed/v19/ieVi2ZhZI2eCN5jzbjEETS9weq8-33mZGCQYaQ.woff) format('woff')}@font-face{font-family:'Roboto Condensed';font-display:block;font-style:normal;font-weight:400;font-display:swap;src:url(https://fonts.gstatic.com/s/robotocondensed/v19/ieVl2ZhZI2eCN5jzbjEETS9weq8-19K7Cw.woff) format('woff')}@font-face{font-family:'Roboto Condensed';font-display:block;font-style:normal;font-weight:700;font-display:swap;src:url(https://fonts.gstatic.com/s/robotocondensed/v19/ieVi2ZhZI2eCN5jzbjEETS9weq8-32meGCQYaQ.woff) format('woff')}</style> <script type='text/javascript' id='mediaelement-js-extra'>var _wpmejsSettings={"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"}</script> <script type='text/javascript' id='wpo_min-footer-0-js-extra'>var wpcf7={"cached":"1"}</script> <script type='text/javascript' src='https://www.lawofficer.com/wp-content/cache/wpo-minify/1618438189/assets/wpo-minify-footer-00b92cb0.min.js' id='wpo_min-footer-0-js'></script> <script type='text/javascript' src='https://www.lawofficer.com/wp-includes/js/mediaelement/wp-mediaelement.min.js' id='wp-mediaelement-js'></script> <script type='text/javascript' id='wpo_min-footer-2-js-extra'>var jnewsoption={"login_reload":"https:\/\/www.lawofficer.com\/ohio-mother-charged-with-murder-after-sons-decomposing-body-found-under-pile-of-clothes","popup_script":"photoswipe","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","language":"en_US","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"116522","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":"","lang":{"invalid_recaptcha":"Invalid Recaptcha!","empty_username":"Please enter your username!","empty_email":"Please enter your email!","empty_password":"Please enter your password!"},"recaptcha":"0","site_slug":"\/","site_domain":"www.lawofficer.com","zoom_button":"0"}</script> <script type='text/javascript' src='https://www.lawofficer.com/wp-content/cache/wpo-minify/1618438189/assets/wpo-minify-footer-ca891beb.min.js' id='wpo_min-footer-2-js'></script> <!--[if lt IE 9]> <script type='text/javascript' src='https://www.lawofficer.com/wp-content/themes/jnews/assets/js/html5shiv.min.js' id='html5shiv-js'></script> <![endif]--> <script type='text/javascript' id='wpo_min-footer-4-js-extra'>var jnews_select_share={"is_customize_preview":""}</script> <script type='text/javascript' src='https://www.lawofficer.com/wp-content/cache/wpo-minify/1618438189/assets/wpo-minify-footer-e17c134d.min.js' id='wpo_min-footer-4-js'></script> <script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js' id='remote_sdk-js'></script> <script type='text/javascript' src='https://www.lawofficer.com/wp-content/cache/wpo-minify/1618438189/assets/wpo-minify-footer-60fd08d5.min.js' id='wpo_min-footer-6-js'></script> <div class="jeg_ad jnews_mobile_sticky_ads "></div><script type='application/ld+json'>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</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"hentry","entry-title":"Ohio mother charged with murder after son&#8217;s decomposing body found under pile of clothes","published":"2021-04-15 08:25:59","updated":"2021-04-15 13:30:51"}</script> <script></script></body></html>

